about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix11
1 files changed, 4 insertions, 7 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index dfb9f41437..3365fe7981 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -106,12 +106,10 @@ in
   # workspace too.
   shell = (import ./shell.nix { inherit pkgs; });
 
-  # Builds and tests the code in castore/protos.
-  castore-protos-go = pkgs.buildGoModule {
-    name = "castore-golang";
-    src = depot.third_party.gitignoreSource ./castore/protos;
-    vendorHash = "sha256-ZNtSSW+oCxMsBtURSrea9/GyUHDagtGefM+Ii+VkgCA=";
-  };
+  # Update `.pb.go` files in tvix/castore-go with the generated ones.
+  castore-go-generate = pkgs.writeShellScriptBin "castore-go-protogen" ''
+    (cd $(git rev-parse --show-toplevel)/tvix/castore-go && rm *.pb.go && cp ${depot.tvix.castore.protos.go-bindings}/*.pb.go . && chmod +w *.pb.go)
+  '';
 
   # Builds and tests the code in store/protos.
   store-protos-go = pkgs.buildGoModule {
@@ -146,7 +144,6 @@ in
   };
 
   meta.ci.targets = [
-    "castore-protos-go"
     "store-protos-go"
     "shell"
     "rust-docs"