about summary refs log tree commit diff
path: root/tvix/cli/src/fetchurl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/cli/src/fetchurl.nix')
-rw-r--r--tvix/cli/src/fetchurl.nix53
1 files changed, 0 insertions, 53 deletions
diff --git a/tvix/cli/src/fetchurl.nix b/tvix/cli/src/fetchurl.nix
deleted file mode 100644
index 3f182a5a31..0000000000
--- a/tvix/cli/src/fetchurl.nix
+++ /dev/null
@@ -1,53 +0,0 @@
-# SPDX-License-Identifier: LGPL-2.1
-#
-# This file is vendored from C++ Nix, as it needs to be bundled with
-# an evaluator to be able to evaluate nixpkgs.
-#
-# Source: https://github.com/NixOS/nix/blob/2.3.16/corepkgs/fetchurl.nix
-
-{ system ? "" # obsolete
-, url
-, hash ? "" # an SRI hash
-
-  # Legacy hash specification
-, md5 ? ""
-, sha1 ? ""
-, sha256 ? ""
-, sha512 ? ""
-, outputHash ? if hash != "" then hash else if sha512 != "" then sha512 else if sha1 != "" then sha1 else if md5 != "" then md5 else sha256
-, outputHashAlgo ? if hash != "" then "" else if sha512 != "" then "sha512" else if sha1 != "" then "sha1" else if md5 != "" then "md5" else "sha256"
-
-, executable ? false
-, unpack ? false
-, name ? baseNameOf (toString url)
-}:
-
-derivation {
-  builder = "builtin:fetchurl";
-
-  # New-style output content requirements.
-  inherit outputHashAlgo outputHash;
-  outputHashMode = if unpack || executable then "recursive" else "flat";
-
-  inherit name url executable unpack;
-
-  system = "builtin";
-
-  # No need to double the amount of network traffic
-  preferLocalBuild = true;
-
-  impureEnvVars = [
-    # We borrow these environment variables from the caller to allow
-    # easy proxy configuration.  This is impure, but a fixed-output
-    # derivation like fetchurl is allowed to do so since its result is
-    # by definition pure.
-    "http_proxy"
-    "https_proxy"
-    "ftp_proxy"
-    "all_proxy"
-    "no_proxy"
-  ];
-
-  # To make "nix-prefetch-url" work.
-  urls = [ url ];
-}