about summary refs log tree commit diff
path: root/tvix/castore/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/castore/Cargo.toml')
-rw-r--r--tvix/castore/Cargo.toml52
1 files changed, 26 insertions, 26 deletions
diff --git a/tvix/castore/Cargo.toml b/tvix/castore/Cargo.toml
index acc1a8bc1284..0744a370f58e 100644
--- a/tvix/castore/Cargo.toml
+++ b/tvix/castore/Cargo.toml
@@ -4,43 +4,43 @@ version = "0.1.0"
 edition = "2021"
 
 [dependencies]
-async-compression = { version = "0.4.9", features = ["tokio", "zstd"]}
+async-compression = { version = "0.4.12", features = ["tokio", "zstd"]}
 async-stream = "0.3.5"
 async-tempfile = "0.4.0"
-blake3 = { version = "1.3.1", features = ["rayon", "std", "traits-preview"] }
-bstr = "1.6.0"
-bytes = "1.4.0"
+blake3 = { version = "1.5.4", features = ["rayon", "std", "traits-preview"] }
+bstr = "1.10.0"
+bytes = "1.7.1"
 data-encoding = "2.6.0"
 digest = "0.10.7"
 fastcdc = { version = "3.1.0", features = ["tokio"] }
 futures = "0.3.30"
-lazy_static = "1.4.0"
-object_store = { version = "0.10.1", features = ["http"] }
-parking_lot = "0.12.1"
-pin-project-lite = "0.2.13"
+lazy_static = "1.5.0"
+object_store = { version = "0.10.2", features = ["http"] }
+parking_lot = "0.12.3"
+pin-project-lite = "0.2.14"
 prost = "0.13.1"
 sled = { version = "0.34.7" }
-thiserror = "1.0.38"
-tokio-stream = { version = "0.1.14", features = ["fs", "net"] }
-tokio-util = { version = "0.7.9", features = ["io", "io-util", "codec"] }
+thiserror = "1.0.63"
+tokio-stream = { version = "0.1.15", features = ["fs", "net"] }
+tokio-util = { version = "0.7.11", features = ["io", "io-util", "codec"] }
 tokio-tar = "0.3.1"
-tokio = { version = "1.32.0", features = ["fs", "macros", "net", "rt", "rt-multi-thread", "signal"] }
-tonic = "0.12.0"
+tokio = { version = "1.39.3", features = ["fs", "macros", "net", "rt", "rt-multi-thread", "signal"] }
+tonic = "0.12.2"
 tower = "0.4.13"
-tracing = "0.1.37"
+tracing = "0.1.40"
 tracing-indicatif = "0.3.6"
 tvix-tracing = { path = "../tracing", features = ["tonic"] }
-url = "2.4.0"
-walkdir = "2.4.0"
-zstd = "0.13.0"
-serde = { version = "1.0.197", features = [ "derive" ] }
-serde_with = "3.7.0"
+url = "2.5.2"
+walkdir = "2.5.0"
+zstd = "0.13.2"
+serde = { version = "1.0.209", features = [ "derive" ] }
+serde_with = "3.9.0"
 serde_qs = "0.12.0"
-petgraph = "0.6.4"
+petgraph = "0.6.5"
 erased-serde = "0.4.5"
 serde_tagged = "0.3.0"
 hyper-util = "0.1.7"
-redb = "2.1.1"
+redb = "2.1.2"
 
 [dependencies.bigtable_rs]
 optional = true
@@ -54,7 +54,7 @@ version = "0.11.0"
 
 [dependencies.libc]
 optional = true
-version = "0.2.144"
+version = "0.2.158"
 
 [dependencies.threadpool]
 version = "1.8.1"
@@ -86,16 +86,16 @@ version = "0.11"
 
 [dependencies.virtio-bindings]
 optional = true
-version = "0.2.1"
+version = "0.2.2"
 
 [build-dependencies]
 prost-build = "0.13.1"
-tonic-build = "0.12.0"
+tonic-build = "0.12.2"
 
 [dev-dependencies]
-async-process = "2.1.0"
+async-process = "2.2.4"
 rstest = "0.19.0"
-tempfile = "3.3.0"
+tempfile = "3.12.0"
 tokio-retry = "0.3.0"
 hex-literal = "0.4.1"
 rstest_reuse = "0.6.0"