about summary refs log tree commit diff
path: root/tvix/build/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/build/Cargo.toml')
-rw-r--r--tvix/build/Cargo.toml18
1 files changed, 9 insertions, 9 deletions
diff --git a/tvix/build/Cargo.toml b/tvix/build/Cargo.toml
index 6a10b41e2eaf..6fd00b5b39a3 100644
--- a/tvix/build/Cargo.toml
+++ b/tvix/build/Cargo.toml
@@ -4,18 +4,18 @@ version = "0.1.0"
 edition = "2021"
 
 [dependencies]
-bytes = "1.4.0"
-clap = { version = "4.0", features = ["derive", "env"] }
-itertools = "0.12.0"
+bytes = "1.7.1"
+clap = { version = "4.5", features = ["derive", "env"] }
+itertools = "0.12.1"
 prost = "0.13.1"
-thiserror = "1.0.56"
-tokio = { version = "1.32.0" }
-tokio-listener = { version = "0.4.1", features = [ "tonic012" ] }
-tonic = { version = "0.12.0", features = ["tls", "tls-roots"] }
+thiserror = "1.0.63"
+tokio = { version = "1.39.3" }
+tokio-listener = { version = "0.4.3", features = [ "tonic012" ] }
+tonic = { version = "0.12.2", features = ["tls", "tls-roots"] }
 tvix-castore = { path = "../castore" }
 tvix-tracing = { path = "../tracing" }
 tracing = "0.1.40"
-url = "2.4.0"
+url = "2.5.2"
 mimalloc = "0.1.43"
 
 [dependencies.tonic-reflection]
@@ -24,7 +24,7 @@ version = "0.12.2"
 
 [build-dependencies]
 prost-build = "0.13.1"
-tonic-build = "0.12.0"
+tonic-build = "0.12.2"
 
 [features]
 default = []