about summary refs log tree commit diff
path: root/tools/url-blocker/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/url-blocker/shell.nix')
-rw-r--r--tools/url-blocker/shell.nix16
1 files changed, 7 insertions, 9 deletions
diff --git a/tools/url-blocker/shell.nix b/tools/url-blocker/shell.nix
index 40f217e3f9a7..1adc566c0121 100644
--- a/tools/url-blocker/shell.nix
+++ b/tools/url-blocker/shell.nix
@@ -1,12 +1,10 @@
 let
-  pkgs = import <unstable> {};
-in pkgs.mkShell {
-  buildInputs = with pkgs; [
-    (haskellPackages.ghcWithPackages (hpkgs: with hpkgs; [
-      time
-      aeson
-      either
-      hspec
-    ]))
+  briefcase = import <briefcase> {};
+in briefcase.buildHaskell.shell {
+  deps = hpkgs: with hpkgs; [
+    time
+    aeson
+    either
+    hspec
   ];
 }