about summary refs log tree commit diff
path: root/tools/nixery/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/nixery/shell.nix')
-rw-r--r--tools/nixery/shell.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/tools/nixery/shell.nix b/tools/nixery/shell.nix
new file mode 100644
index 0000000000..b91094722c
--- /dev/null
+++ b/tools/nixery/shell.nix
@@ -0,0 +1,13 @@
+# Copyright 2022 The TVL Contributors
+# SPDX-License-Identifier: Apache-2.0
+
+# Configures a shell environment that builds required local packages to
+# run Nixery.
+{ pkgs ? import <nixpkgs> { } }:
+
+let nixery = import ./default.nix { inherit pkgs; };
+in pkgs.stdenv.mkDerivation {
+  name = "nixery-dev-shell";
+
+  buildInputs = with pkgs; [ jq nixery.nixery-prepare-image ];
+}