about summary refs log tree commit diff
path: root/tools/nixery/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/nixery/default.nix')
-rw-r--r--tools/nixery/default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/nixery/default.nix b/tools/nixery/default.nix
index 74cb588a39..657f110395 100644
--- a/tools/nixery/default.nix
+++ b/tools/nixery/default.nix
@@ -27,7 +27,10 @@ let
 
   # If Nixery is built outside of depot, it needs to dynamically fetch
   # the current nix-1p.
-  nix-1p-git = builtins.fetchGit "https://code.tvl.fyi/depot.git:/nix/nix-1p.git";
+  nix-1p-git = builtins.fetchGit {
+    url = "https://code.tvl.fyi/depot.git:/nix/nix-1p.git";
+    ref = "canon";
+  };
 in
 depot.nix.readTree.drvTargets rec {
   # Implementation of the Nix image building logic