about summary refs log tree commit diff
path: root/tools/magrathea/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/magrathea/default.nix')
-rw-r--r--tools/magrathea/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/tools/magrathea/default.nix b/tools/magrathea/default.nix
new file mode 100644
index 0000000000..fa0a5d89a1
--- /dev/null
+++ b/tools/magrathea/default.nix
@@ -0,0 +1,23 @@
+# magrathea helps you build planets
+#
+# it is a tool for working with monorepos in the style of tvl's depot
+{ pkgs, ... }:
+
+pkgs.stdenv.mkDerivation {
+  name = "magrathea";
+  src = ./.;
+  dontInstall = true;
+
+  nativeBuildInputs = [ pkgs.chicken ];
+  buildInputs = with pkgs.chickenPackages.chickenEggs; [
+    matchable
+    srfi-13
+  ];
+
+  propagatedBuildInputs = [ pkgs.git ];
+
+  buildPhase = ''
+    mkdir -p $out/bin
+    csc -o $out/bin/mg -static ${./mg.scm}
+  '';
+}