about summary refs log tree commit diff
path: root/tools/gotest/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/gotest/default.nix')
-rw-r--r--tools/gotest/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/tools/gotest/default.nix b/tools/gotest/default.nix
new file mode 100644
index 0000000000..4396cd9b47
--- /dev/null
+++ b/tools/gotest/default.nix
@@ -0,0 +1,27 @@
+# This file demonstrates how to make use of pkgs.buildGo.
+#
+# It introduces libraries and protobuf support, however gRPC support
+# is not yet included.
+#
+# From the root of this repository this example can be built with
+# `nix-build -A tools.gotest`
+{ pkgs, ... }:
+
+let
+  inherit (pkgs) buildGo;
+
+  somelib = buildGo.package {
+    name = "somelib";
+    srcs = [ ./lib.go ];
+  };
+
+  someproto = buildGo.proto {
+    name = "someproto";
+    proto = ./test.proto;
+  };
+
+in buildGo.program {
+  name = "gotest";
+  srcs = [ ./main.go ];
+  deps = [ somelib someproto ];
+}