about summary refs log tree commit diff
path: root/tools/eaglemode/plugins/avif/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/eaglemode/plugins/avif/default.nix')
-rw-r--r--tools/eaglemode/plugins/avif/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/tools/eaglemode/plugins/avif/default.nix b/tools/eaglemode/plugins/avif/default.nix
new file mode 100644
index 000000000000..5def86a6ed82
--- /dev/null
+++ b/tools/eaglemode/plugins/avif/default.nix
@@ -0,0 +1,16 @@
+{ depot, pkgs, ... }:
+
+let
+  em = depot.tools.eaglemode;
+  emSrc = pkgs.srcOnly pkgs.em;
+in
+(em.buildPlugin {
+  name = "avif";
+  version = "canon";
+  src = ./.;
+  target = "PlAvif";
+}).overrideAttrs
+  ({ buildInputs ? [ ], nativeBuildInputs ? [ ], ... }: {
+    buildInputs = buildInputs ++ [ pkgs.libavif ];
+    nativeBuildInputs = nativeBuildInputs ++ [ pkgs.pkg-config ];
+  })