about summary refs log tree commit diff
path: root/tools/eaglemode/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/eaglemode/default.nix')
-rw-r--r--tools/eaglemode/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/eaglemode/default.nix b/tools/eaglemode/default.nix
index eade62c02898..0b0c0caa8ba8 100644
--- a/tools/eaglemode/default.nix
+++ b/tools/eaglemode/default.nix
@@ -63,6 +63,11 @@ rec {
     '')
   );
 
+  # mkTGA converts the given image to a TGA image.
+  mkTGA = name: path: pkgs.runCommand "${name}.tga" { } ''
+    ${pkgs.imagemagick}/bin/convert ${path} $out
+  '';
+
   # etcDir creates a directory layout suitable for use in the EM_USER_CONFIG_DIR
   # environment variable.
   #