about summary refs log tree commit diff
path: root/tools/eaglemode/commands/emacsclient.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/eaglemode/commands/emacsclient.nix')
-rw-r--r--tools/eaglemode/commands/emacsclient.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/tools/eaglemode/commands/emacsclient.nix b/tools/eaglemode/commands/emacsclient.nix
index d5aacd137fdc..bac3674120ee 100644
--- a/tools/eaglemode/commands/emacsclient.nix
+++ b/tools/eaglemode/commands/emacsclient.nix
@@ -1,8 +1,13 @@
 { depot, pkgs, ... }:
 
-depot.tools.eaglemode.mkCommand {
+let
+  em = depot.tools.eaglemode;
+  icon = em.mkTGA "emacs" "${pkgs.emacs}/share/icons/hicolor/128x128/apps/emacs.png";
+in
+em.mkCommand {
   name = "Emacsclient";
   hotkey = "Ctrl+E";
+  icon = "${icon}";
 
   description = ''
     Open target in Emacsclient.