about summary refs log tree commit diff
path: root/tools/eaglemode/commands/B.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/eaglemode/commands/B.nix')
-rw-r--r--tools/eaglemode/commands/B.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/tools/eaglemode/commands/B.nix b/tools/eaglemode/commands/B.nix
new file mode 100644
index 000000000000..bca3d3a87a87
--- /dev/null
+++ b/tools/eaglemode/commands/B.nix
@@ -0,0 +1,23 @@
+{ depot, pkgs, ... }:
+
+let
+  em = depot.tools.eaglemode;
+in
+em.mkCommand {
+  name = "9 B";
+  hotkey = "Ctrl+E";
+  icon = "${./plan9.tga}";
+
+  description = ''
+    Plumb target to Sam or Acme
+  '';
+
+  code = ''
+    ErrorIfNotSingleTarget();
+
+    my @tgt=GetTgt();
+    my $dir=$tgt[0];
+
+    ExecOrError('${pkgs.plan9port}/bin/9', 'B', $dir);
+  '';
+}