about summary refs log tree commit diff
path: root/tools/depotfmt.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/depotfmt.nix')
-rw-r--r--tools/depotfmt.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/depotfmt.nix b/tools/depotfmt.nix
index 097bc29b45..8a72149203 100644
--- a/tools/depotfmt.nix
+++ b/tools/depotfmt.nix
@@ -8,6 +8,11 @@ let
     command = "${pkgs.go}/bin/gofmt"
     options = [ "-w" ]
     includes = ["*.go"]
+
+    [formatter.tf]
+    command = "${pkgs.terraform}/bin/terraform"
+    options = [ "fmt" ]
+    includes = [ "*.tf" ]
   '';
 in pkgs.writeShellScriptBin "depotfmt" ''
   exec ${pkgs.treefmt}/bin/treefmt ''${@} \