about summary refs log tree commit diff
path: root/tools/cheddar/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/cheddar/default.nix')
-rw-r--r--tools/cheddar/default.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/tools/cheddar/default.nix b/tools/cheddar/default.nix
index c8d7ba5ffe..8d37694c00 100644
--- a/tools/cheddar/default.nix
+++ b/tools/cheddar/default.nix
@@ -9,4 +9,15 @@ depot.third_party.naersk.buildPackage {
     # plus additional languages we care about.
     BAT_SYNTAXES = "${depot.third_party.bat_syntaxes}";
   };
+
+  passthru = {
+    # Wrapper for cgit which can't be told to pass arguments to a filter
+    about-filter = pkgs.writeShellScriptBin "cheddar-about" ''
+      exec ${depot.tools.cheddar}/bin/cheddar --about-filter $@
+    '';
+  };
+
+  meta.targets = [
+    "about-filter"
+  ];
 }