about summary refs log tree commit diff
path: root/third_party/rustsec-advisory-db/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rustsec-advisory-db/default.nix')
-rw-r--r--third_party/rustsec-advisory-db/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/third_party/rustsec-advisory-db/default.nix b/third_party/rustsec-advisory-db/default.nix
new file mode 100644
index 000000000000..3d3b387be84f
--- /dev/null
+++ b/third_party/rustsec-advisory-db/default.nix
@@ -0,0 +1,24 @@
+# RustSec's advisory db for crates
+#
+# Update using:
+#
+#   nix-prefetch-git --quiet --url https://github.com/RustSec/advisory-db.git > third_party/rustsec-advisory-db/pin.json
+#
+# TODO(Profpatsch): automatically update in regular intervals
+{ pkgs, ... }:
+
+let
+  pin = builtins.fromJSON (builtins.readFile ./pin.json);
+
+  date = builtins.head (builtins.split "T" pin.date);
+in
+
+pkgs.fetchFromGitHub {
+  name = "advisory-db-${date}";
+  owner = "RustSec";
+  repo = "advisory-db";
+  inherit (pin)
+    rev
+    sha256
+  ;
+}