about summary refs log tree commit diff
path: root/third_party/python/broadlink/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/python/broadlink/default.nix')
-rw-r--r--third_party/python/broadlink/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/third_party/python/broadlink/default.nix b/third_party/python/broadlink/default.nix
new file mode 100644
index 0000000000..b1dcf30081
--- /dev/null
+++ b/third_party/python/broadlink/default.nix
@@ -0,0 +1,16 @@
+# Python package for controlling the Broadlink RM Pro Infrared
+# controller.
+#
+# https://github.com/mjg59/python-broadlink
+{ pkgs, lib, ... }:
+
+let
+  inherit (pkgs) fetchFromGitHub;
+  inherit (pkgs.python3Packages) buildPythonPackage cryptography;
+in
+buildPythonPackage (lib.fix (self: {
+  pname = "python-broadlink";
+  version = "0.13.2";
+  src = ./.;
+  propagatedBuildInputs = [ cryptography ];
+}))