about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index 4997e97c50..fbc48e1565 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -6,11 +6,14 @@ self: super:
 let
   # Rollback Nix to a stable version (2.3) with backports for
   # build-user problems applied.
-  nixSrc = builtins.fetchGit {
-    url = "https://github.com/tvlfyi/nix.git";
-    ref = "2.3-backport-await-users";
-    #hash = "sha256:0jnwrzxh04d0pyhx4n8fg4w1w6ak48byl5k2i8j7fk4h9vd9649k";
-  };
+  nixSrc = self.fetchFromGitHub
+    {
+      owner = "tvlfyi";
+      repo = "nix";
+      # branch 2.3-backport-await-users
+      rev = "880a62b08443a6baa55dab027b69bb8b1551a588";
+      hash = "sha256:0jnwrzxh04d0pyhx4n8fg4w1w6ak48byl5k2i8j7fk4h9vd9649k";
+    } // { revCount = 0; shortRev = "880a62b0"; };
 in
 {
   nix = (import "${nixSrc}/release.nix" {