about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index 1b2f2b9792..7b2bb12fca 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -46,9 +46,11 @@ self: super: {
   nix-serve = super.nix-serve.override { nix = super.nix_2_3; };
 
   # Avoid builds of mkShell derivations in CI.
-  mkShell = super.lib.makeOverridable (args: (super.mkShell args) // {
-    meta.ci.skip = true;
-  });
+  mkShell = super.lib.makeOverridable (args: (super.mkShell args).overrideAttrs (_: {
+    passthru = {
+      meta.ci.skip = true;
+    };
+  }));
 
   # bump nixpkgs-fmt to a version that doesn't touch whitespace in
   # strings