about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index 5c654287b275..217d2017f24e 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -140,6 +140,11 @@ depot.nix.readTree.drvTargets {
     patches = (old.patches or [ ]) ++ [ ./patches/tpm2-pkcs11-190-dbupgrade.patch ];
   });
 
+  # Dependency isn't supported by Python 3.12
+  html5validator = super.html5validator.override {
+    python3 = self.python311;
+  };
+
   # macFUSE bump containing fix for https://github.com/osxfuse/osxfuse/issues/974
   # https://github.com/NixOS/nixpkgs/pull/320197
   fuse =
@@ -152,9 +157,4 @@ depot.nix.readTree.drvTargets {
             hash = "sha256-ucTzO2qdN4QkowMVvC3+4pjEVjbwMsB0xFk+bvQxwtQ=";
           };
         }) else super.fuse;
-
-  treefmt = super.treefmt.overrideAttrs (old: {
-    # https://github.com/numtide/treefmt/pull/328
-    patches = old.patches or [ ] ++ [ ./patches/treefmt-fix-no-cache.patch ];
-  });
 }