about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix14
1 files changed, 11 insertions, 3 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index c68ec8f262..2a99e66c74 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -39,14 +39,22 @@ depot.nix.readTree.drvTargets {
   nix = self.nix_2_3;
   nix_latest = super.nix;
 
+  # nixos-option now unfortunately depends on (at the time of writing) Nix 2.15
+  # instead of Nix 2.3 as before. The intention seems to be to keep it in sync
+  # with the latest Nix and it uses unstable interfaces of Nix (the libraries).
+  # TODO(sterni): can we link it statically and avoid a second Nix store path?
+  nixos-option = super.nixos-option.override {
+    nix = self.nix_latest;
+  };
+
   # Too match telega in emacs-overlay or wherever
   tdlib = super.tdlib.overrideAttrs (_: {
-    version = "1.8.14";
+    version = "1.8.15";
     src = self.fetchFromGitHub {
       owner = "tdlib";
       repo = "td";
-      rev = "e8ee1c51498c060c6f9b8511bf25a6c025e72adf";
-      sha256 = "0vm5j5kzvzf5gdmg2rg6hw3dyzn9dy0l256asyjipbnhk9302s0n";
+      rev = "64264b0f775a027fa9e0bf72051a8b2a5a2df071";
+      sha256 = "1qs8pizap7glm98kjjliph1s7dn4fffwvs5ml8nv9d55dispjc4f";
     };
   });