about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index 600161b661..fb2a89e7fd 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -148,7 +148,12 @@ depot.nix.readTree.drvTargets {
     };
   };
 
-  clickhouse = super.clickhouse.overrideAttrs (old: {
+  # we're vendoring this for now, since the version upgrade has a lot of changes
+  # we can't merge it upstream yet because the Darwin build is broken
+  # https://github.com/NixOS/nixpkgs/pull/267033
+  clickhouse = (super.callPackage ./clickhouse {
+    llvmPackages = super.llvmPackages_16;
+  }).overrideAttrs (old: {
     patches = old.patches or [ ] ++ [
       # https://github.com/ClickHouse/ClickHouse/pull/56118
       ./patches/clickhouse-support-reading-arrow-LargeListArray.patch