about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index 80f6f04fcf..d0a0d5581c 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -1,6 +1,6 @@
 # This overlay is used to make TVL-specific modifications in the
 # nixpkgs tree, where required.
-{ depot, ... }:
+{ depot, localSystem, ... }:
 
 self: super:
 let
@@ -30,8 +30,8 @@ in
   nix = (import "${nixSrc}/release.nix" {
     nix = nixSrc;
     nixpkgs = super.path;
-    systems = [ builtins.currentSystem ];
-  }).build."${builtins.currentSystem}";
+    systems = [ localSystem ];
+  }).build."${localSystem}";
 
   nix_latest = super.nix;