about summary refs log tree commit diff
path: root/third_party/overlays/tvl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/overlays/tvl.nix')
-rw-r--r--third_party/overlays/tvl.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/third_party/overlays/tvl.nix b/third_party/overlays/tvl.nix
index 3482b7416b..7c7c8ea06a 100644
--- a/third_party/overlays/tvl.nix
+++ b/third_party/overlays/tvl.nix
@@ -28,4 +28,12 @@ self: super: {
       tvlPackages = depot.tools.emacs-pkgs // depot.third_party.emacs;
     })
   );
+
+  # Temporary fix for python3Packages.notmuch
+  # See https://github.com/NixOS/nixpkgs/pull/132592/
+  notmuch = super.notmuch.overrideAttrs(old: {
+    passthru = old.passthru // {
+      pythonSourceRoot = "notmuch-${old.version}/bindings/python";
+    };
+  });
 }