about summary refs log tree commit diff
path: root/third_party/overlays/haskell/extra-pkgs/pa-json-0.2.0.0.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/overlays/haskell/extra-pkgs/pa-json-0.2.0.0.nix')
-rw-r--r--third_party/overlays/haskell/extra-pkgs/pa-json-0.2.0.0.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/third_party/overlays/haskell/extra-pkgs/pa-json-0.2.0.0.nix b/third_party/overlays/haskell/extra-pkgs/pa-json-0.2.0.0.nix
new file mode 100644
index 0000000000..56ee6eb2d1
--- /dev/null
+++ b/third_party/overlays/haskell/extra-pkgs/pa-json-0.2.0.0.nix
@@ -0,0 +1,43 @@
+{ mkDerivation
+, aeson
+, aeson-better-errors
+, aeson-pretty
+, base
+, bytestring
+, containers
+, hspec-core
+, hspec-expectations
+, lib
+, pa-error-tree
+, pa-label
+, pa-prelude
+, scientific
+, text
+, time
+, vector
+}:
+mkDerivation {
+  pname = "pa-json";
+  version = "0.2.0.0";
+  sha256 = "b57ef3888b8ea3230925675eccd6affbc3d296fc8762f5937435af4bdbd276e4";
+  libraryHaskellDepends = [
+    aeson
+    aeson-better-errors
+    aeson-pretty
+    base
+    bytestring
+    containers
+    hspec-core
+    hspec-expectations
+    pa-error-tree
+    pa-label
+    pa-prelude
+    scientific
+    text
+    time
+    vector
+  ];
+  homepage = "https://github.com/possehl-analytics/pa-hackage";
+  description = "Our JSON parsers/encoders";
+  license = lib.licenses.bsd3;
+}