about summary refs log tree commit diff
path: root/third_party/nix/tests/timeout.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/tests/timeout.nix')
-rw-r--r--third_party/nix/tests/timeout.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/third_party/nix/tests/timeout.nix b/third_party/nix/tests/timeout.nix
deleted file mode 100644
index d0e949e314..0000000000
--- a/third_party/nix/tests/timeout.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-with import ./config.nix;
-
-{
-
-  infiniteLoop = mkDerivation {
-    name = "timeout";
-    buildCommand = ''
-      touch $out
-      echo "'timeout' builder entering an infinite loop"
-      while true ; do echo -n .; done
-    '';
-  };
-
-  silent = mkDerivation {
-    name = "silent";
-    buildCommand = ''
-      touch $out
-      sleep 60
-    '';
-  };
-
-  closeLog = mkDerivation {
-    name = "silent";
-    buildCommand = ''
-      touch $out
-      exec > /dev/null 2>&1
-      sleep 1000000000
-    '';
-  };
-
-}