about summary refs log tree commit diff
path: root/third_party/nix/tests/run.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/tests/run.nix')
-rw-r--r--third_party/nix/tests/run.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/third_party/nix/tests/run.nix b/third_party/nix/tests/run.nix
new file mode 100644
index 0000000000..77dcbd2a9d
--- /dev/null
+++ b/third_party/nix/tests/run.nix
@@ -0,0 +1,17 @@
+with import ./config.nix;
+
+{
+  hello = mkDerivation {
+    name = "hello";
+    buildCommand =
+      ''
+        mkdir -p $out/bin
+        cat > $out/bin/hello <<EOF
+        #! ${shell}
+        who=\$1
+        echo "Hello \''${who:-World} from $out/bin/hello"
+        EOF
+        chmod +x $out/bin/hello
+      '';
+  };
+}