about summary refs log tree commit diff
path: root/third_party/nix/tests/import-derivation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/tests/import-derivation.nix')
-rw-r--r--third_party/nix/tests/import-derivation.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/third_party/nix/tests/import-derivation.nix b/third_party/nix/tests/import-derivation.nix
deleted file mode 100644
index 44fa9a45d7..0000000000
--- a/third_party/nix/tests/import-derivation.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-with import ./config.nix;
-
-let
-
-  bar = mkDerivation {
-    name = "bar";
-    builder = builtins.toFile "builder.sh"
-      ''
-        echo 'builtins.add 123 456' > $out
-      '';
-  };
-
-  value =
-    # Test that pathExists can check the existence of /nix/store paths
-    assert builtins.pathExists bar;
-    import bar;
-
-in
-
-mkDerivation {
-  name = "foo";
-  builder = builtins.toFile "builder.sh"
-    ''
-      echo -n FOO${toString value} > $out
-    '';
-}