about summary refs log tree commit diff
path: root/third_party/nix/test-vm.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/test-vm.nix')
-rw-r--r--third_party/nix/test-vm.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/third_party/nix/test-vm.nix b/third_party/nix/test-vm.nix
new file mode 100644
index 0000000000..8b00e5515b
--- /dev/null
+++ b/third_party/nix/test-vm.nix
@@ -0,0 +1,20 @@
+{ depot, pkgs, ... }:
+
+let
+  configuration = { ... }: {
+    imports = [
+      "${pkgs.path}/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix"
+    ];
+
+    nix.package = depot.third_party.nix;
+
+    virtualisation.qemu.options = [ "-nographic" "-curses" ];
+
+    nix.nixPath = [
+      "depot=${depot.path}"
+    ];
+  };
+
+  system = depot.third_party.nixos { inherit configuration; };
+in
+system.vm