about summary refs log tree commit diff
path: root/third_party/nix/src/tests/lang/parse-fail-undef-var-2.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/src/tests/lang/parse-fail-undef-var-2.nix')
-rw-r--r--third_party/nix/src/tests/lang/parse-fail-undef-var-2.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/third_party/nix/src/tests/lang/parse-fail-undef-var-2.nix b/third_party/nix/src/tests/lang/parse-fail-undef-var-2.nix
new file mode 100644
index 0000000000..c10a52b1ea
--- /dev/null
+++ b/third_party/nix/src/tests/lang/parse-fail-undef-var-2.nix
@@ -0,0 +1,7 @@
+let {
+
+  f = {x, y : ["baz" "bar" z "bat"]}: x + y;
+
+  body = f {x = "foo"; y = "bar";};
+
+}