about summary refs log tree commit diff
path: root/third_party/nix/src/tests/lang/disabled/eval-okay-search-path.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/src/tests/lang/disabled/eval-okay-search-path.nix')
-rw-r--r--third_party/nix/src/tests/lang/disabled/eval-okay-search-path.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/third_party/nix/src/tests/lang/disabled/eval-okay-search-path.nix b/third_party/nix/src/tests/lang/disabled/eval-okay-search-path.nix
new file mode 100644
index 0000000000..cca41f821f
--- /dev/null
+++ b/third_party/nix/src/tests/lang/disabled/eval-okay-search-path.nix
@@ -0,0 +1,11 @@
+with import ./lib.nix;
+with builtins;
+
+assert pathExists <nix/buildenv.nix>;
+
+assert length __nixPath == 6;
+assert length (filter (x: x.prefix == "nix") __nixPath) == 1;
+assert length (filter (x: baseNameOf x.path == "dir4") __nixPath) == 1;
+
+import <a.nix> + import <b.nix> + import <c.nix> + import <dir5/c.nix>
+  + (let __nixPath = [ { path = ./dir2; } { path = ./dir1; } ]; in import <a.nix>)