about summary refs log tree commit diff
path: root/third_party/nix/src/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/src/tests/CMakeLists.txt')
-rw-r--r--third_party/nix/src/tests/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/third_party/nix/src/tests/CMakeLists.txt b/third_party/nix/src/tests/CMakeLists.txt
index cda8f5da84..f8158d06c3 100644
--- a/third_party/nix/src/tests/CMakeLists.txt
+++ b/third_party/nix/src/tests/CMakeLists.txt
@@ -66,3 +66,13 @@ target_link_libraries(language-tests
 )
 
 gtest_discover_tests(language-tests)
+
+add_executable(store-api-test store-api-test.cc)
+target_link_libraries(store-api-test
+  nixstore
+  rapidcheck
+  rapidcheck_gtest
+  GTest::gtest_main
+)
+
+gtest_discover_tests(store-api-test)