about summary refs log tree commit diff
path: root/third_party/nix/src/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/src/tests/CMakeLists.txt')
-rw-r--r--third_party/nix/src/tests/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/third_party/nix/src/tests/CMakeLists.txt b/third_party/nix/src/tests/CMakeLists.txt
index 33f4f774a6..929acc5ea6 100644
--- a/third_party/nix/src/tests/CMakeLists.txt
+++ b/third_party/nix/src/tests/CMakeLists.txt
@@ -30,6 +30,15 @@ target_link_libraries(hash_test
 
 gtest_discover_tests(hash_test)
 
+add_executable(store_test store_tests.cc)
+target_link_libraries(store_test
+  nixstore
+  nixstoremock
+  GTest::gtest_main
+)
+
+gtest_discover_tests(store_test)
+
 add_executable(value-to-json value-to-json.cc)
 target_link_libraries(value-to-json
   nixexpr