about summary refs log tree commit diff
path: root/third_party/nix/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/shell.nix')
-rw-r--r--third_party/nix/shell.nix24
1 files changed, 0 insertions, 24 deletions
diff --git a/third_party/nix/shell.nix b/third_party/nix/shell.nix
deleted file mode 100644
index e163fccf9c..0000000000
--- a/third_party/nix/shell.nix
+++ /dev/null
@@ -1,24 +0,0 @@
-let pkgs = (import <nixpkgs> {}).third_party;
-in with pkgs;
-
-with import ./release-common.nix { inherit pkgs; };
-
-clangStdenv.mkDerivation {
-  name = "nix";
-
-  buildInputs = buildDeps ++ propagatedDeps ++ tarballDeps ++ perlDeps;
-
-  inherit configureFlags;
-
-  enableParallelBuilding = true;
-
-  installFlags = "sysconfdir=$(out)/etc";
-
-  shellHook =
-    ''
-      export prefix=$(pwd)/inst
-      configureFlags+=" --prefix=$prefix"
-      PKG_CONFIG_PATH=$prefix/lib/pkgconfig:$PKG_CONFIG_PATH
-      PATH=$prefix/bin:$PATH
-    '';
-}