about summary refs log tree commit diff
path: root/third_party/nix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/default.nix')
-rw-r--r--third_party/nix/default.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/third_party/nix/default.nix b/third_party/nix/default.nix
index ad1ff5beeb..b4f16d02c7 100644
--- a/third_party/nix/default.nix
+++ b/third_party/nix/default.nix
@@ -1,5 +1,8 @@
 { pkgs ? (import ../.. {}).third_party
-, buildType ? "release", ... }:
+, buildType ? "release"
+, depotPath ? ../..
+, ...
+}:
 
 let
   aws-s3-cpp = pkgs.aws-sdk-cpp.override {
@@ -115,6 +118,10 @@ in pkgs.llvmPackages.libcxxStdenv.mkDerivation {
     ln -s $out/bin/nix $out/libexec/nix/build-remote
   '';
 
+  shellHook = ''
+    export NIX_DATA_DIR="${toString depotPath}/third_party"
+  '';
+
   # TODO(tazjin): integration test setup?
   # TODO(tazjin): docs generation?
 }