about summary refs log tree commit diff
path: root/third_party/nix/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/CMakeLists.txt')
-rw-r--r--third_party/nix/CMakeLists.txt32
1 files changed, 6 insertions, 26 deletions
diff --git a/third_party/nix/CMakeLists.txt b/third_party/nix/CMakeLists.txt
index fad650a7cade..4e6b209c3699 100644
--- a/third_party/nix/CMakeLists.txt
+++ b/third_party/nix/CMakeLists.txt
@@ -15,35 +15,15 @@ set(PKGCONFIG_INSTALL_DIR ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
 # contain useful definitions. Other dependencies are not treated
 # specially by CMake and are only linked into the resulting binary.
 find_package(BZip2)
-find_package(Boost COMPONENTS context) # probably coroutine + ::headers, lets find out
+find_package(Boost COMPONENTS context)
 find_package(CURL)
+find_package(LibLZMA)
+find_package(Protobuf REQUIRED)
 find_package(SQLite3)
 find_package(Threads)
-find_package(LibLZMA)
-
-# Abseil really doesn't like being precompiled. It is included here as
-# an imported CMake project (i.e. it will be built /with/ this
-# project).
-#
-# In development mode, the 'abseil_cpp' folder is symlinked to
-# ../abseil_cpp (the relative location in the depot). In derivation
-# builds this symlink is automatically replaced with an appropriate
-# link to the Abseil sources in the Nix store.
-add_subdirectory(abseil_cpp)
-install(DIRECTORY abseil_cpp/absl
-  DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
-  FILES_MATCHING
-    PATTERN "*.inc"
-    PATTERN "*.h"
-    PATTERN "copts" EXCLUDE
-    PATTERN "testdata" EXCLUDE
-  )
-
-# Linking precompiled glog binaries (linked against libstdc++) leads
-# to working binaries that do not output log messages. It seems that
-# in order to use glog with LLVM & libc++, one needs to make glog a
-# part of the local project build.
-add_subdirectory(glog)
+find_package(absl REQUIRED)
+find_package(gRPC REQUIRED)
+find_package(glog REQUIRED)
 
 # generate a configuration file (autoheader-style) to configure
 # certain symbols that Nix depends on.