about summary refs log tree commit diff
path: root/third_party/nix/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/CMakeLists.txt')
-rw-r--r--third_party/nix/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/third_party/nix/CMakeLists.txt b/third_party/nix/CMakeLists.txt
index fb7076aa5f..88a23cd880 100644
--- a/third_party/nix/CMakeLists.txt
+++ b/third_party/nix/CMakeLists.txt
@@ -11,7 +11,6 @@ find_package(Boost COMPONENTS context) # probably coroutine + ::headers, lets fi
 find_package(CURL)
 find_package(SQLite3)
 find_package(Threads)
-find_package(glog)
 find_package(LibLZMA)
 
 # Abseil really doesn't like being precompiled. It is included here as
@@ -24,6 +23,12 @@ find_package(LibLZMA)
 # link to the Abseil sources in the Nix store.
 add_subdirectory(abseil_cpp)
 
+# Linking precompiled glog binaries (linked against libstdc++) leads
+# to working binaries that do not output log messages. It seems that
+# in order to use glog with LLVM & libc++, one needs to make glog a
+# part of the local project build.
+add_subdirectory(glog)
+
 # generate a configuration file (autoheader-style) to configure
 # certain symbols that Nix depends on.
 configure_file(config.h.in nix_config.h @ONLY)