about summary refs log tree commit diff
path: root/third_party/nix/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/CMakeLists.txt')
-rw-r--r--third_party/nix/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/third_party/nix/CMakeLists.txt b/third_party/nix/CMakeLists.txt
index 88a23cd880..012a63bcb9 100644
--- a/third_party/nix/CMakeLists.txt
+++ b/third_party/nix/CMakeLists.txt
@@ -3,6 +3,10 @@ cmake_minimum_required(VERSION 3.16)
 project(nix CXX)
 set(CMAKE_CXX_STANDARD 17)
 
+# Export compile_commands.json which can be used by tools such as
+# clangd and clang-tidy.
+set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
+
 # The following lines import CMake-native dependencies which may
 # contain useful definitions. Other dependencies are not treated
 # specially by CMake and are only linked into the resulting binary.