about summary refs log tree commit diff
path: root/third_party/nix/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/CMakeLists.txt')
-rw-r--r--third_party/nix/CMakeLists.txt19
1 files changed, 1 insertions, 18 deletions
diff --git a/third_party/nix/CMakeLists.txt b/third_party/nix/CMakeLists.txt
index fad650a7ca..35fc003dd7 100644
--- a/third_party/nix/CMakeLists.txt
+++ b/third_party/nix/CMakeLists.txt
@@ -20,24 +20,7 @@ find_package(CURL)
 find_package(SQLite3)
 find_package(Threads)
 find_package(LibLZMA)
-
-# Abseil really doesn't like being precompiled. It is included here as
-# an imported CMake project (i.e. it will be built /with/ this
-# project).
-#
-# In development mode, the 'abseil_cpp' folder is symlinked to
-# ../abseil_cpp (the relative location in the depot). In derivation
-# builds this symlink is automatically replaced with an appropriate
-# link to the Abseil sources in the Nix store.
-add_subdirectory(abseil_cpp)
-install(DIRECTORY abseil_cpp/absl
-  DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
-  FILES_MATCHING
-    PATTERN "*.inc"
-    PATTERN "*.h"
-    PATTERN "copts" EXCLUDE
-    PATTERN "testdata" EXCLUDE
-  )
+find_package(absl REQUIRED)
 
 # Linking precompiled glog binaries (linked against libstdc++) leads
 # to working binaries that do not output log messages. It seems that