about summary refs log tree commit diff
path: root/third_party/nix/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/nix/CMakeLists.txt')
-rw-r--r--third_party/nix/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/third_party/nix/CMakeLists.txt b/third_party/nix/CMakeLists.txt
index e37bef9383..200b604c22 100644
--- a/third_party/nix/CMakeLists.txt
+++ b/third_party/nix/CMakeLists.txt
@@ -40,7 +40,9 @@ if (CLANG_TIDY_PATH)
   endif()
 endif()
 
-if (NOT SANDBOX_SHELL)
+if (DEFINED ENV{SANDBOX_SHELL})
+  set(SANDBOX_SHELL ENV{SANDBOX_SHELL})
+else()
   find_program(BUSYBOX busybox)
   if (BUSYBOX)
     set(SANDBOX_SHELL "${BUSYBOX}")