about summary refs log tree commit diff
path: root/third_party/lisp/usocket.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/usocket.nix')
-rw-r--r--third_party/lisp/usocket.nix17
1 files changed, 9 insertions, 8 deletions
diff --git a/third_party/lisp/usocket.nix b/third_party/lisp/usocket.nix
index 920c41c58d..888d5e01a0 100644
--- a/third_party/lisp/usocket.nix
+++ b/third_party/lisp/usocket.nix
@@ -1,14 +1,15 @@
 # Usocket is a portable socket library
-{ depot, ... }:
+{ depot, pkgs, ... }:
 
-with depot.nix;
+let
+  inherit (depot.nix) buildLisp;
 
-let src = depot.third_party.fetchFromGitHub {
-  owner = "usocket";
-  repo = "usocket";
-  rev = "fdf4fd1e0051ce83340ccfbbc8a43a462bb19cf2";
-  sha256 = "0x746wr2324l6bn7skqzgkzcbj5kd0zp2ck0c8rldrw0rzabg826";
-};
+  src = pkgs.fetchFromGitHub {
+    owner = "usocket";
+    repo = "usocket";
+    rev = "fdf4fd1e0051ce83340ccfbbc8a43a462bb19cf2";
+    sha256 = "0x746wr2324l6bn7skqzgkzcbj5kd0zp2ck0c8rldrw0rzabg826";
+  };
 in buildLisp.library {
   name = "usocket";
   deps = with depot.third_party.lisp; [