about summary refs log tree commit diff
path: root/third_party/lisp/trivial-gray-streams.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/trivial-gray-streams.nix')
-rw-r--r--third_party/lisp/trivial-gray-streams.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/third_party/lisp/trivial-gray-streams.nix b/third_party/lisp/trivial-gray-streams.nix
new file mode 100644
index 0000000000..62a30f1e94
--- /dev/null
+++ b/third_party/lisp/trivial-gray-streams.nix
@@ -0,0 +1,13 @@
+# Portability library for CL gray streams.
+{ depot, pkgs, ... }:
+
+let src = with pkgs; srcOnly lispPackages.trivial-gray-streams;
+in depot.nix.buildLisp.library {
+  name = "trivial-gray-streams";
+  srcs = [
+    (src + "/package.lisp")
+    (src + "/streams.lisp")
+  ];
+}
+
+