about summary refs log tree commit diff
path: root/third_party/lisp/s-xml/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/s-xml/default.nix')
-rw-r--r--third_party/lisp/s-xml/default.nix18
1 files changed, 10 insertions, 8 deletions
diff --git a/third_party/lisp/s-xml/default.nix b/third_party/lisp/s-xml/default.nix
index 3cd13ffb6b..486e1c1ac8 100644
--- a/third_party/lisp/s-xml/default.nix
+++ b/third_party/lisp/s-xml/default.nix
@@ -1,15 +1,17 @@
 # XML serialiser for Common Lisp.
 { depot, pkgs, ... }:
 
-let src = pkgs.applyPatches {
-  name = "s-xml-source";
-  src = pkgs.lispPackages.s-xml.src;
+let
+  src = pkgs.applyPatches {
+    name = "s-xml-source";
+    src = pkgs.lispPackages.s-xml.src;
 
-  patches = [
-    ./0001-fix-definition-order-in-xml.lisp.patch
-  ];
-};
-in depot.nix.buildLisp.library {
+    patches = [
+      ./0001-fix-definition-order-in-xml.lisp.patch
+    ];
+  };
+in
+depot.nix.buildLisp.library {
   name = "s-xml";
 
   srcs = map (f: src + ("/src/" + f)) [