about summary refs log tree commit diff
path: root/third_party/lisp/routes.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/routes.nix')
-rw-r--r--third_party/lisp/routes.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/third_party/lisp/routes.nix b/third_party/lisp/routes.nix
new file mode 100644
index 0000000000..61c6749660
--- /dev/null
+++ b/third_party/lisp/routes.nix
@@ -0,0 +1,28 @@
+{ depot, pkgs, ... }:
+
+let
+
+  src = pkgs.fetchFromGitHub {
+    owner = "archimag";
+    repo = "cl-routes";
+    rev = "1b79e85aa653e1ec87e21ca745abe51547866fa9";
+    sha256 = "1zpk3cp2v8hm50ppjl10yxr437vv4552r8hylvizglzrq2ibsbr1";
+  };
+
+in depot.nix.buildLisp.library {
+  name = "routes";
+
+  deps = with depot.third_party.lisp; [
+    puri
+    iterate
+    split-sequence
+  ];
+
+  srcs = map (f: src + ("/src/" + f)) [
+    "package.lisp"
+    "uri-template.lisp"
+    "route.lisp"
+    "mapper.lisp"
+  ];
+
+}