about summary refs log tree commit diff
path: root/third_party/lisp/rfc2388.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/rfc2388.nix')
-rw-r--r--third_party/lisp/rfc2388.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/third_party/lisp/rfc2388.nix b/third_party/lisp/rfc2388.nix
new file mode 100644
index 0000000000..b82a490c9d
--- /dev/null
+++ b/third_party/lisp/rfc2388.nix
@@ -0,0 +1,12 @@
+# Implementation of RFC2388 (multipart/form-data)
+{ depot, pkgs, ... }:
+
+let src = with pkgs; srcOnly lispPackages.rfc2388;
+in depot.nix.buildLisp.library {
+  name = "rfc2388";
+
+  srcs = map (f: src + ("/" + f)) [
+    "packages.lisp"
+    "rfc2388.lisp"
+  ];
+}