about summary refs log tree commit diff
path: root/third_party/lisp/restas.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/restas.nix')
-rw-r--r--third_party/lisp/restas.nix41
1 files changed, 0 insertions, 41 deletions
diff --git a/third_party/lisp/restas.nix b/third_party/lisp/restas.nix
deleted file mode 100644
index cf231286e7..0000000000
--- a/third_party/lisp/restas.nix
+++ /dev/null
@@ -1,41 +0,0 @@
-{ depot, pkgs, ... }:
-
-let
-
-  src = pkgs.fetchFromGitHub {
-    owner = "archimag";
-    repo = "restas";
-    rev = "81bbbab6b36f81f846f78e71232e9d3d15f6d952";
-    sha256 = "00ng6jik1lwjw3bbxhijy8s0ml24lgm73liwrr01gcsb0r6wrjjn";
-  };
-
-in depot.nix.buildLisp.library {
-  name = "restas";
-  deps = with depot.third_party.lisp; [
-    cffi
-    hunchentoot
-    bordeaux-threads
-    routes
-    alexandria
-    data-sift
-  ];
-
-  srcs = map (f: src + ("/src/" + f)) [
-    "packages.lisp"
-    "special.lisp"
-    "declarations.lisp"
-    "errors.lisp"
-    "render.lisp"
-    "context.lisp"
-    "module.lisp"
-    "route.lisp"
-    "decorators.lisp"
-    "vhost.lisp"
-    "hunchentoot.lisp"
-    "policy.lisp"
-  ];
-
-  brokenOn = [
-    "ecl" # dynamic cffi
-  ];
-}