about summary refs log tree commit diff
path: root/third_party/lisp/physical-quantities.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/physical-quantities.nix')
-rw-r--r--third_party/lisp/physical-quantities.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/third_party/lisp/physical-quantities.nix b/third_party/lisp/physical-quantities.nix
new file mode 100644
index 0000000000..6e124a9132
--- /dev/null
+++ b/third_party/lisp/physical-quantities.nix
@@ -0,0 +1,30 @@
+{ depot, pkgs, ... }:
+
+let
+  src = pkgs.fetchFromGitHub {
+    owner = "mrossini-ethz";
+    repo = "physical-quantities";
+    rev = "8feb66ef3293fcb9ff4c4bd3ee872bfc385a590e";
+    sha256 = "1qznv0hmn2n7g9dxx1iw0qpr0pf2lnbahn0x0b3v50xzcb65kgig";
+  };
+in depot.nix.buildLisp.library {
+  name = "physical-quantities";
+
+  deps = with depot.third_party.lisp; [
+    parseq
+  ];
+
+  srcs = map (f: src + ("/" + f)) [
+    "package.lisp"
+    "utils.lisp"
+    "conditions.lisp"
+    "unit-factor.lisp"
+    "unit-database.lisp"
+    "units.lisp"
+    "quantity.lisp"
+    "numeric.lisp"
+    "parse-rules.lisp"
+    "read-macro.lisp"
+    "si-units.lisp"
+  ];
+}