about summary refs log tree commit diff
path: root/third_party/lisp/parseq.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/parseq.nix')
-rw-r--r--third_party/lisp/parseq.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/third_party/lisp/parseq.nix b/third_party/lisp/parseq.nix
new file mode 100644
index 0000000000..23c67c2d9c
--- /dev/null
+++ b/third_party/lisp/parseq.nix
@@ -0,0 +1,13 @@
+{ depot, pkgs, ... }:
+
+let src = with pkgs; srcOnly lispPackages.parseq;
+in depot.nix.buildLisp.library {
+  name = "parseq";
+
+  srcs = map (f: src + ("/" + f)) [
+    "package.lisp"
+    "conditions.lisp"
+    "utils.lisp"
+    "defrule.lisp"
+  ];
+}