about summary refs log tree commit diff
path: root/third_party/lisp/md5.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/md5.nix')
-rw-r--r--third_party/lisp/md5.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/third_party/lisp/md5.nix b/third_party/lisp/md5.nix
new file mode 100644
index 0000000000..8c3e255f16
--- /dev/null
+++ b/third_party/lisp/md5.nix
@@ -0,0 +1,16 @@
+# MD5 hash implementation
+{ depot, pkgs, ... }:
+
+with depot.nix;
+
+let src = with pkgs; srcOnly lispPackages.md5;
+in buildLisp.library {
+  name = "md5";
+  deps = [
+    {
+      sbcl = buildLisp.bundled "sb-rotate-byte";
+      default = depot.third_party.lisp.flexi-streams;
+    }
+  ];
+  srcs = [ (src + "/md5.lisp") ];
+}