about summary refs log tree commit diff
path: root/third_party/lisp/marshal.nix
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/lisp/marshal.nix')
-rw-r--r--third_party/lisp/marshal.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/third_party/lisp/marshal.nix b/third_party/lisp/marshal.nix
new file mode 100644
index 0000000000..73a1664a01
--- /dev/null
+++ b/third_party/lisp/marshal.nix
@@ -0,0 +1,13 @@
+{ depot, pkgs, ... }:
+
+let src = with pkgs; srcOnly lispPackages.marshal;
+in depot.nix.buildLisp.library {
+  name = "marshal";
+  srcs = map (f: src + ("/" + f)) [
+    "package.lisp"
+    "serialization-format.lisp"
+    "coding-idiom.lisp"
+    "marshal.lisp"
+    "unmarshal.lisp"
+  ];
+}